Cómo comprobar si hay plugins vulnerables en tu WordPress

Dificultad: Fácil
Tiempo de Lectura: 2 minutos

En esta oportunidad tocaremos un tema muy importante para la seguridad: los plugins vulnerables en WordPress. Además, siguiendo algunos pasos vamos a lograr que nuestros plugins no representen una vulnerabilidad en nuestro sitio. Recordemos que el hecho de contar con vulnerabilidades siempre termina causando malware, spam y el en peor de los casos hackeos indeseados.

¿Cómo nos aseguramos de no contar con plugins vulnerables?

Primero que nada recordemos lo que ya hemos dicho en un post anterior, y es que si bien los plugins integran nuevas funciones y hacen que nuestra web luzca mucho mejor, son junto con los themes uno de los grandes problemas de vulnerabilidad y lentitud asociados a WordPress. Con esto en mente, primero que nada debemos de eliminar todos los plugins que no necesitemos y también los que no estemos utilizando.

Una vez que hemos hecho esto pasaremos a centrarnos en mejorar los que sí usaremos.

Medidas a seguir para evitar los plugins vulnerables

  • Como primera medida debemos eliminar todos los plugins que no estemos usando, pues aún estando deshabilitados pueden suponer un riesgo para nuestra web.
  • Segundo debemos tener todos los plugins al día (actualizados), así como también themes y también WordPress en sí. Para evitar tener plugins vulnerables es imprescindible que estén al día.
  • En tercer lugar debemos de mantenernos informados: Wordpress cuenta con muchos plugins y es normal que periódicamente sean encontrados plugins vulnerables. Es muy importante informarnos y en caso de estar utilizando un plugin vulnerable, eliminarlo, al menos hasta que haya una actualización de seguridad que nos asegure que es nuevamente confiable. Sucuri ofrece a través de su blog informes sobre fallos críticos en WordPress, por ejemplo, y sitios como ese hay miles.
  • Como cuarta medida, podemos instalar un plugin que verifique las vulnerabilidades del resto de los plugins. Entre las opciones más comunes tenemos algunos como ‘Plugin Security Scanner‘ y ‘Plugin Vulnerabilities‘. Son muy fáciles de instalar y te aseguran que si hay plugins vulnerables serán detectados, y por supuesto recibirás una notificación para tomar medidas.
  • Otro punto muy importante es instalar siempre plugins que sean oficiales y nunca instalar plugins de lugares desconocidos o sospechosos, así como tampoco aquellos que dejaron de ser actualizados.

 

Si sigues estos simples pasos verás que la seguridad de tu instalación de WordPress mejorará mucho. Los plugins suelen ser una de las principales entradas a un sitio preferidas por hackers y terceros malintencionados, así que dejar de lado los plugins vulnerables es una medida imprescindible para contar con un sitio seguro.


¿Te resultó útil el artículo? Compártelo con tus colegas: